搜索
开启辅助访问 切换到宽版

QQ登录

只需一步,快速开始

扫一扫,访问微社区

注册 找回密码
查看: 2024|回复: 1

centos7下使用phpstudy安装opencart失败

[复制链接]
发表于 2023-6-16 21:13:33 | 显示全部楼层 |阅读模式
phpstudy V1.29
opencart-v38-ifree-20220308
四个安装步骤都能完成,并且出现网站前台和管理员后台的链接页面,但是点开报HTTP ERROR 500
日志error.log中报
AH01071: Got error 'PHP message: PHP Fatal error:  Declaration of DebugBar\\DataCollector\\PDO\\TraceablePDO::query($statement) must be compatible with PDO::query(string $query, ?int $fetchMode = null, mixed ...$fetchModeArgs) in /www/admin/upload/vendor/maximebf/debugbar/src/DebugBar/DataCollector/PDO/TraceablePDO.php on line 146', referer: https://124.221.81.102/install/index.php?route=install/step_4
回复

使用道具 举报

发表于 2023-7-28 09:59:18 | 显示全部楼层
PHP版本7.2,检查下
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

关闭

站长推荐 上一条 /1 下一条

QQ|手机版|OpenCart - 中文官方网站 ( 蜀ICP备09033774号|人工智能

GMT+8, 2024-4-23 09:44 , Processed in 0.070339 second(s), 20 queries , Gzip On.

快速回复 返回顶部 返回列表